Задать вопрос

Вводится массив, состоящий из целых чисел. Найти наибольшее среди них. Входные данные Сначала задано число N - количество элементов в массиве (1N35). Далее через пробел записаны N чисел - элементы массива. Массив состоит из целых чисел. Выходные данные Необходимо вывести значение наибольшего элемента в массиве. Примеры Входные данные 3 1 2 3 Выходные данные 3

+4
Ответы (1)
  1. 28 июля, 18:41
    0
    program zz1;

    var i, max1, n:integer; / / задаем переменные целого типа

    m:array [1 ... 100] of integer;

    begin

    write (' введите заданное число n '); / / вводим количество элементов в массиве

    read (n);

    for i:=1 to n do / / записываем в массив числа с клавиатуры

    read (m[i]);

    max1:=0; / / задаем начальное значение для наибольшего элемента

    for i:=1 to n do / / находим максимальный элемент

    if m[i]>max1 / / проверяем, если очередной элемент больше максимального, то записываем его в максимальный

    then max1:=m[i];

    writeln (' максимальный элемент = ', max1); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Вводится массив, состоящий из целых чисел. Найти наибольшее среди них. Входные данные Сначала задано число N - количество элементов в ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дан массив, состоящий из целых чисел. Напишите программу, которая в данном массиве определит количество элементов, у которых два соседних и, при этом, оба соседних элемента меньше данного.
Ответы (1)
Дан массив, состоящий из целых чисел. Напишите программу, которая подсчитает количество элементов массива, больших предыдущего (элемента с предыдущим номером). Входные данные Сначала задано число N - количество элементов в массиве (1N10000).
Ответы (1)
Сначала задано число N - количество элементов в массиве. Далее через пробел записаны N чисел - элементы массива. Необходимо вывести все четные элементы массива (то есть те элементы, которые являются четными числами).
Ответы (1)
Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данныхСначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива.
Ответы (1)
Напишите программу, которая находит в массиве самую длинную цепочку одинаковых элементов. Программа должна вывести значение элемента, который встречается наибольшее число раз подряд, и длину этой цепочки.
Ответы (1)