Задать вопрос

Составьте программу, которая заполняет массив а[1 ... 10] случайными целыми числами в диапозоне от 0 до 10, затем первый элемент меняет местами с максимальным элементом. Выведите на экран исходный и полученный массивы.

+5
Ответы (1)
  1. 4 февраля, 16:37
    0
    var a: array[1 ... 10] of integer;

    amin, amax, aimin, aimax, i: integer;

    begin

    writeln ('Включаем генератор случайных чисел');

    randomize;

    writeln ('Заполняем массив случайными числами');

    for i : = 1 to 10 do a[i] : = random (10);

    writeln ('Выводим исходный массив');

    for i : = 1 to 10 do write (a[i]:4);

    writeln ('Ищем минимальный элемент и его позицию');

    aimax:=1;

    aimin:=1;

    for i:=1 to 1 do begin

    if a[i] > a[aimax] then aimax:=i

    else if a[i] < a[aimin] then aimin:=i;

    end;

    writeln ('Меняем минимальный и максимальный элементы местами');

    amax : = a[aimax];

    amin : = a[aimin];

    a[aimax] : = amin;

    a[aimin] : = amax;

    writeln ('Выводим новый массив');

    for i : = 1 to 10 do write (a[i]:4);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу, которая заполняет массив а[1 ... 10] случайными целыми числами в диапозоне от 0 до 10, затем первый элемент меняет ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Составьте программу, которая заполняет массив a[1 ... 100] случайными целыми числами в диапозоне от 1 до 100, затем меняет местами максимальный и минимальный элементы.
Ответы (1)
Составить программу для решения следующей задачи: Дан массив целых чисел, заполненный случайными числами в диапазоне [-100, 100]. Замените все отрицательные элементы максимальным. Выведите на экран исходный и измененный массивы.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Напишите программу, которая заполняет с клавиатуры массив А (3,3) словами разного размера и заменяет самое короткое слово главной диагонали на максимальное по длине слово всего массива. Выведите на экран исходный и полученный массивы.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)