Задать вопрос

Напишите программу, которая заполняет с клавиатуры массив А (3,3) словами разного размера и заменяет самое короткое слово главной диагонали на максимальное по длине слово всего массива. Выведите на экран исходный и полученный массивы.

+3
Ответы (1)
  1. 13 декабря, 19:57
    0
    program arr;

    var a: array [1 ... 3,1 ... 3] of string;

    //макс. и мин. длина слова, индексы макс. элемента

    max, min, imax, jmax: integer;

    begin

    max:=1; min:=100;

    writeln ('Введите 9 слов');

    for i: = 1 to 3 do

    for j: = 1 to 3 do

    begin

    readln (a[i, j]);

    if length (a[i, j]) > max then

    begin

    max: = length (a[i, j]); imax:=i; jmax:=j;

    end;

    if (length (a[i, j]) < min) and (i=j) then

    begin

    min: = length (a[i, j]);

    end;

    end;

    for i: = 1 to 3 do

    for j: = 1 to 3 do if j<3 then write (a[i, j] : 20)

    else writeln (a[i, j] : 20);

    writeln ();

    for i: = 1 to 3 do

    for j: = 1 to 3 do

    begin

    if (i = j) and (length (a[i, j]) = min) then a[i, j]: = a[imax, jmax];

    if j < 3 then write (a[i, j] : 20) else writeln (a[i, j] : 20);

    end

    end.

    Программа заменяет все самые короткие элементы диагонали на первый наибольший элемент.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу, которая заполняет с клавиатуры массив А (3,3) словами разного размера и заменяет самое короткое слово главной диагонали ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Составьте программу, которая заполняет массив а[1 ... 10] случайными целыми числами в диапозоне от 0 до 10, затем первый элемент меняет местами с максимальным элементом. Выведите на экран исходный и полученный массивы.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными индексами. выведите на экран исходный массив и полученное среднее арифметическое. 2.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика целых случайных чисел. Найдите сумму четных элементов массива. Выведите на экран исходный массив и полученную сумму. 2. Дан массив В (n). Определите произведение элементов, кратных 3.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)