Задать вопрос

Написать программу на языке Паскаль Дано: а, b, с Найти:S S=SQRT (p (p-a) (p-b) (p-c)) где р = (а+b+c) / 2

+3
Ответы (1)
  1. 24 августа, 03:19
    0
    program zz1;

    var a, b, c, p, S:real; / / задаем переменные не целого типа

    begin

    write (' введите первый коэффициент '); / / вводим с клавиатуры первое число

    read (a);

    write (' введите второй коэффициент '); / / вводим с клавиатуры второе число

    read (b);

    write (' введите третий коэффициент '); / / вводим с клавиатуры третье число

    read (c);

    p: = (a + b + c) / 2; / / рассчитываем полупериметр

    S: = sqrt (p * (p - a) * (p - b) * (p - c)); / / находим площадь по формуле

    Write (' S = ', S); / / выводим ответ

    END.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу на языке Паскаль Дано: а, b, с Найти:S S=SQRT (p (p-a) (p-b) (p-c)) где р = (а+b+c) / 2 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Написать программу в паскале для p=1*1/2*1/3 ... 1/n и s = sqrt (1) + sqrt (1+2) + sqrt (1+3) ... sqrt (1+n)
Ответы (1)
1) Написать программу на языке Паскаль, которая вычисляет среднее арифметическое пяти любых чисел. 2) Написать программу на языке Паскаль, вычисляющую корни квадратного уравнения.
Ответы (1)
Напишите программу нахождения длин медиан m1, m2 и m3, треугольника по указанными формулами. Длина сторон a, b, c задается с клавиатуры m1=1/2*sqrt (2a^2+2b^2-c^2); m2=1/2*sqrt (2a^2+2c^2-b^2); m3=1/4*sqrt (2b^2+2c^2-a^2);.
Ответы (1)
1. Дано двузначное число. Найти разность и частное его цифр. 2. Дано целое число. Если оно является положительным то прибавить к нему 1. Емли нулевым то заменить его на 10. 3. Дано двузначное число. Вывести его левую цифру, потом правую. 4.
Ответы (1)
Написать на языке паскаль программу ввода четырех целых чисел и вычисления их среднего арифметического. протестировать программу на различных исходных данных и доказать правильность ее работы
Ответы (1)