Задать вопрос

Написать программу в паскале для p=1*1/2*1/3 ... 1/n и s = sqrt (1) + sqrt (1+2) + sqrt (1+3) ... sqrt (1+n)

+2
Ответы (1)
  1. 11 января, 07:28
    0
    program ps;

    var n: integer;

    s, p: real;

    begin

    write ('n = ');

    readln (n); / / ввод числа n

    s: = 0; / / начальное значение суммы s

    p: = 1; / / начальное значение произведения p

    for i: integer: = 1 to n do

    begin

    s: = s + sqrt (i); / / добавление к имеющемуся значению s корня из числа i

    p: = p * (1 / i); / / умножение имеющегося произведения на (1/i)

    end;

    writeln ('p = ', p : 10 : 8, ' s = ', s : 10 : 8) / / вывод результата

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу в паскале для p=1*1/2*1/3 ... 1/n и s = sqrt (1) + sqrt (1+2) + sqrt (1+3) ... sqrt (1+n) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Написать программу в паскале! Написать программу при помощи процедуры, которая по известному радиусу возвращает в основную программу значения площади круга и длины окружности.
Ответы (1)
Напишите программу нахождения длин медиан m1, m2 и m3, треугольника по указанными формулами. Длина сторон a, b, c задается с клавиатуры m1=1/2*sqrt (2a^2+2b^2-c^2); m2=1/2*sqrt (2a^2+2c^2-b^2); m3=1/4*sqrt (2b^2+2c^2-a^2);.
Ответы (1)
Напишите программу в Паскале) написать программу которая вычисляет дату следующего дня. Введите цифрами сегодняшнюю дату (число, месяц, год) 31 12 1998
Ответы (1)
Написать программу в Паскале. Программу вывода на экран всех чисел кратных 3 и 5 от 1 до 1000
Ответы (1)
1) Как можно описать на Паскале 1) Как можно описать на Паскале массив, в котором будет храниться значения численности населения Москвы к концу каждого года XX века?2) Вы приобрели котёнка. Каждый вечер вы определяете его вес с помощью весов.
Ответы (1)