Задать вопрос

Составить программу классификации треугольников по его сторонам (вместо углов входными данными являются стороны треугольника a, b, c.)

+5
Ответы (1)
  1. 5 сентября, 01:00
    0
    program zz1;

    var

    a, b, c: real; //задаем переменные не целого типа

    begin

    write ('введите первую сторону треугольника ');

    read (a); / / вводим с клавиатуры первую сторону треугольника

    write ('введите вторую сторону треугольника ');

    read (b); / / вводим с клавиатуры вторую сторону треугольника

    write ('введите третью сторону треугольника ');

    read (c); / / вводим с клавиатуры третью сторону треугольника

    if (a = c) or (a = b) or (c = a) then write (' треугольник равнобедренный '); / / проверяем стороны и выводим ответ

    if (a = c) and (a = b) and (c = a) then write (' треугольник равносторонний ');

    if (a c) and (a b) and (c a) then write (' треугольник разносторонний ');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу классификации треугольников по его сторонам (вместо углов входными данными являются стороны треугольника a, b, c.) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике