Войти
Задать вопрос
Илья Ермаков
Информатика
30 августа, 17:18
Даны натуральные числа а, n. Вычислить a (a-n) (a-2n) ... (a-n*n). через паскаль
+3
Ответы (
1
)
Виктория Осипова
30 августа, 17:45
0
program zz1;
var
i, n, a, p: integer; / / задаем переменные целого типа
begin
write (' введите первое заданное число a '); / / вводим с клавиатуры первое натуральное число
read (a);
write (' введите второе заданное число n '); / / вводим с клавиатуры второе натуральное число
read (n);
p:=1; / / задаем начальное значение для произведения
for i:=0 to n do / / организуем цикл, на n+1 повторений
p:=p*a-i*n; / / вычисляем значение выражения по заданной формуле
write (' результат = ', p); / / выводим ответ
end.
Комментировать
Жалоба
Ссылка
Знаешь ответ на этот вопрос?
Отправить
Новые вопросы по информатике
Написать программу нахождения суммы трёх целых чисел
Ответы (1)
Укажи минимальный объём памяти (в килобайтах), достаточный для хранения любого растрового изображения размером 128*128 пиксела, если известно, что в изображении используется палитра из 256 цветов. Саму палитру хранить не нужно.
Ответы (1)
Рассчитайте время звучания моноаудиофайла, если при 16-битовом кодировании и частоте дискретизации 32000 его объём равен 3500 Кбайт.
Ответы (1)
var a, R : integer; Function F (x : integer) : integer; begin if x< = 0 then F:=0 else F:=x + F (x-2); end; begin a:=8; R:=F (a); write (R); end. В паскале ответ 20, как он получается? объясните поподробнее
Ответы (1)
Написать программу в паскале для вычисления суммы ряда Sn=1+1/2+1/3 + ... + 1/n, где n - натуральное число, вводимое с клавиатуры
Ответы (1)
Главная
»
Информатика
» Даны натуральные числа а, n. Вычислить a (a-n) (a-2n) ... (a-n*n). через паскаль
Войти
Регистрация
Забыл пароль