Задать вопрос

Даны два натуральных числа m и n. Проверить, есть ли в записи числа m цифры, одинаковые с цифрами в записи числа n. P. S. На языке паскаль.

+3
Ответы (1)
  1. 16 января, 04:20
    0
    program test;

    var n, m, k: integer;

    sn, sm, ch: string;

    begin

    writeln ('Введите числа m и n через пробел');

    readln (m, n);

    str (n, sn); / /преобразование числа n в строку

    str (m, sm); //преобразование числа m в строку

    for i:integer:=1 to length (sm) do / /цикл поиска одинаковых цифр

    / / + вложенный цикл удаления найденных цифр из строки sn (из числа n)

    begin

    ch:=copy (sm, i, 1); //в ch поочередно помещаются цифры первого числа;

    //если очередная цифра есть во втором числе, то выводится сообщение

    if pos (ch, sn) >0 then writeln (ch, ' входит в состав числа ', n);

    k:=1;

    //Цикл удаления найденной совпадающей цифры из строки sn (из числа n)

    while k0 do

    begin

    k:=pos (ch, sn);

    delete (sn, k, 1);

    end

    end

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Даны два натуральных числа m и n. Проверить, есть ли в записи числа m цифры, одинаковые с цифрами в записи числа n. P. S. На языке паскаль. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. 2) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом).
Ответы (1)
Запишите на языке Паскаль следующие условия. Условие Запись на языке Паскаль х не кратно 7 У ≠ 0 - 5
Ответы (1)
1) Написать программу на языке Паскаль, которая вычисляет среднее арифметическое пяти любых чисел. 2) Написать программу на языке Паскаль, вычисляющую корни квадратного уравнения.
Ответы (1)
Вывести целое число и определить верно ли, что в его записи есть две одинаковые цифры. Например, 1234 - нет; 1224 - да. Обязательно должен присутствовать цикл с предусловием while do. Информатика. 8 класс. Паскаль ABC.
Ответы (1)
Напишите программу на языке паскаль, которая вычесляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) всех чётных чисел в диапазоне от 1 до n; г) всех двузначных чисел.
Ответы (1)