Задать вопрос

1. Вычислить значение переменной Y при заданном значении N: Y=1/1+1/2+1/3 + ... + 1/N. использовать цикл типа ДО. (Паскаль) 2. Найти все целые двузначные числа, удовлетворящие условию: остаток от деления на 3 равен 2. (Паскаль)

+1
Ответы (1)
  1. 18 апреля, 16:05
    0
    1)

    program sum_1_na_n;

    var y: real;

    i, N:integer;

    begin

    writeln ('Введите значение N.');

    readln (N);

    i : = 0;

    y : = 0;

    repeat

    i : =i + 1;

    y : = y + 1/i;

    until i = N;

    writeln ('Cумма y = ', y : 8 : 4)

    end.

    2)

    program ost;

    var i: integer;

    begin

    i : = 1;

    repeat

    if (i - 3 * int (i/3) = 2) then write (i, ' ');

    if i mod 10 = 0 then writeln; / /Числа каждого десятка в новой строке

    i:=i + 1;

    until i = 99;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1. Вычислить значение переменной Y при заданном значении N: Y=1/1+1/2+1/3 + ... + 1/N. использовать цикл типа ДО. (Паскаль) 2. Найти все ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Составить программу, которая находит минимальное натуральное число х, такое, что остаток от деления х на 10 равен 9, остаток от деления х на 9 равен 8, остаток от деления х на 8 равен 7, ... остаток от деления х на 2 равен 1.
Ответы (1)
Запишите на алгоритмическом языке алгоритм, в результате которого переменной а будет присвоено значение переменной Ь, переменной b - значение переменной с, а переменной с - значение переменной а. Используйте не более одной промежуточной переменной.
Ответы (1)
1. какие команды присваивания составлены правильно? a) A: = В б) А=В в) А=B+1 г) А+1:=А 2. Сколько промежуточных переменных потребуется для того, чтобы переменной А было присвоено значение переменной В, переменной В - значение переменной С, а
Ответы (1)
Напечатать столбиком : a) все целые числа от 10 до 35; b) квадраты все целых чисел от 5 до n; c) третьи степени всех целых чисел от а до 50; d) все целые числа от а до b. Использовать оператор While
Ответы (1)
Даны целые положительные числа N и K. Используя только операции сложения и вычитания, найти частное от деления нацело N на K, а также остаток от этого деления.
Ответы (1)