Задать вопрос

Вычислить А=К + 40, если значение К больше 15, но меньше 25. При других значениях К вычислить В=М+1. значение М задается константой, К вводится с клавиатуры

+5
Ответы (1)
  1. 9 февраля, 02:10
    0
    Введем следующие обозначения: m - заданная константа; k - число, значение которого будем вводить с клавиатуры во время выполнения программы; a, b - числа, которые надо найти в зависимости от значения введенного числа k. Тогда программа на языке программирования Pascal ABC может выглядеть так:

    program zadacha;

    uses crt;

    const m=5;

    var a, b, k: integer;

    begin

    writeln ('vvedite chislo k');

    readln (k);

    if (k>15) and (k<25)

    then begin a:=k+40; writeln ('a=', a); end

    else begin b:=m+1; writeln ('b=', b); end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Вычислить А=К + 40, если значение К больше 15, но меньше 25. При других значениях К вычислить В=М+1. значение М задается константой, К ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напечатать "столбиком": а) все целые числа от 20 до 35; б) квадраты всех целых чисел от 10 до b (значение b вводится с клавиатуры; b > (или равно) 10); в) третьи степени всех целых чисел от a до 50 (значение а вводится с клавиатуры; а (или равно) а).
Ответы (1)
1). Составить программу, которая выводит на экран сумму, произведение и средние арифметическое кубов всех целых чисел от a до, b. (Значение переменных a и b вводится с клавиатуры). 2).
Ответы (1)
Найти среднее арифметическое элементов последовательности, превосходящих некоторое число C. Массив задан с клавиатуры. Размер произвольный. Значение C вводится с клавиатуры.
Ответы (1)
1. Найти сумму элементов массива принадлежащих промежутку от C до D (C и D вводятся с клавиатуры). 2. Определить есть ли в данном массиве положительные элементы кратные k (k вводится с клавиатуры). Паскаль
Ответы (1)
С клавиатуры вводится число n. Заполнить массив с клавиатуры n значениями и вывести их в обратном порядке
Ответы (1)