Задать вопрос

Напечатать "столбиком": а) все целые числа от 20 до 35; б) квадраты всех целых чисел от 10 до b (значение b вводится с клавиатуры; b > (или равно) 10); в) третьи степени всех целых чисел от a до 50 (значение а вводится с клавиатуры; а (или равно) а).

+4
Ответы (1)
  1. 4 ноября, 23:09
    0
    а) program zz1;

    var c:integer; / / задаем переменную целого типа

    begin

    c:=20; / / задаем начальное значение

    while c < = 35 do / / организуем цикл, пока переменная не достигнет последнего значения

    begin

    writeln (c); / / выводим ответ

    c:=c + 1;

    end;

    end.

    b) program zz1;

    var c, b:integer; / / задаем переменные целого типа

    begin

    read (b);

    c:=10; / / задаем начальное значение

    while c < = b do / / организуем цикл, пока переменная не достигнет последнего значения

    begin

    writeln (c*c); / / выводим ответ

    c:=c + 1;

    end;

    end.

    c) program zz1;

    var a:integer; / / задаем переменную целого типа

    begin

    read (a);

    while a < = 50 do / / организуем цикл, пока переменная не достигнет последнего значения

    begin

    writeln (a*a*a); / / выводим ответ

    a:=a + 1;

    end;

    end.

    d) program zz1;

    var a, b:integer; / / задаем переменные целого типа

    begin

    read (a, b);

    while a < = b do / / организуем цикл, пока переменная не достигнет последнего значения

    begin

    writeln (a); / / выводим ответ

    a:=a + 1;

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напечатать "столбиком": а) все целые числа от 20 до 35; б) квадраты всех целых чисел от 10 до b (значение b вводится с клавиатуры; b > (или ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напечатать столбиком : a) все целые числа от 10 до 35; b) квадраты все целых чисел от 5 до n; c) третьи степени всех целых чисел от а до 50; d) все целые числа от а до b. Использовать оператор While
Ответы (1)
Напечатать столбиком все целые чётные числа от 14 до 24 и квадраты этих чисел. Решение вида: Число Квадрат 14 196 16 256 18 324 20 400 22 441 24 576
Ответы (1)
Дана непустая последовательность целых чисел, оканчивающаяся нулем (0 является признаком окончания последовательности и в последовательность не входит). Найти и напечатать: 1. Сумму всех чисел, больших Х (значение Х вводится с клавиатуры).
Ответы (1)
В одномерном массиве из 20 целых чисел напечатать номера элементов, значение которых больше числа D. Переменная D вводится с клавиатуры.
Ответы (1)
1). Составить программу, которая выводит на экран сумму, произведение и средние арифметическое кубов всех целых чисел от a до, b. (Значение переменных a и b вводится с клавиатуры). 2).
Ответы (1)