Задать вопрос

Дан массив А содержащий только 1 и 0 массив заполняется через read и data определите количество нулей и единиц в этом массиве

+5
Ответы (1)
  1. 25 сентября, 06:45
    0
    program zz1;

    const n = 3; / / задаем количество элементов в массиве

    var i, j, k, v:integer; / / задаем переменные целого типа

    a:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел с клавиатуры и записываем их в массив

    read (a[i]);

    for i:=1 to n do

    if a[i] = 0 then k:=k+1 else v:=v+1; / / проверяем, если элемент массива равен нулю, то считаем один ответ, если не равен нулю, то другой

    writeln (' количество нулей в массиве = ', k); / / выводим ответы

    write (' количество единиц в массиве = ', v);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан массив А содержащий только 1 и 0 массив заполняется через read и data определите количество нулей и единиц в этом массиве ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Решите одно из предложенных, умоляю дан массив А5 найти сумму и количество положительных элементов дан массив А5 определить количество отрицательных элементов дан массив А6 определить количество положительных элементов
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
Дан массив, содержащий 2015 положительных целых чисел. Напишите на одном из языков программирования программу, которая находит в этом массиве количество локальных минимумов, значение которых кратно 3.
Ответы (1)
Дан массив, содержащий 2016 неотрицательных целых чисел. Необходимо найти в этом массиве количество таких элементов, которые равны среднему арифметическому двух элементов, расположенных непосредственно перед ним.
Ответы (1)
Дан массив, состоящий из целых чисел. Напишите программу, которая в данном массиве определит количество элементов, у которых два соседних и, при этом, оба соседних элемента меньше данного.
Ответы (1)