Задать вопрос

Дан массив, состоящий из целых чисел. Напишите программу, которая в данном массиве определит количество элементов, у которых два соседних и, при этом, оба соседних элемента меньше данного. Входные данные Сначала задано число N - количество элементов в массиве (1N100). Далее через пробел записаны N чисел - элементы массива. Массив состоит из целых чисел. Выходные данные Необходимо вывести количество элементов массива, у которых два соседа и которые при этом строго больше обоих своих соседей. Примеры Входные данные 5 1 2 3 4 5 Выходные данные 0 Входные данные 5 1 5 1 5 1 Выходные данные 2

+2
Ответы (1)
  1. 15 марта, 21:51
    0
    program zz1;

    const n = 10; / / задаем количество чисел в массиве

    var i, s, k:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (51);

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i:=2 to n - 1 do / / организуем цикл, в котором переберем все числа массива

    begin

    if (m[i] > m[i + 1]) and (m[i] > m[i - 1]) then

    s:=s + 1; / / проверяем, если очередной элемент массива строго больше обоих своих соседей, то считаем его

    end;

    writeln (' количество локальных максимумов = ', s); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан массив, состоящий из целых чисел. Напишите программу, которая в данном массиве определит количество элементов, у которых два соседних ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Вводится массив, состоящий из целых чисел. Найти наибольшее среди них. Входные данные Сначала задано число N - количество элементов в массиве (1N35). Далее через пробел записаны N чисел - элементы массива. Массив состоит из целых чисел.
Ответы (1)
Дан массив, состоящий из целых чисел. Напишите программу, которая подсчитает количество элементов массива, больших предыдущего (элемента с предыдущим номером). Входные данные Сначала задано число N - количество элементов в массиве (1N10000).
Ответы (1)
Сначала задано число N - количество элементов в массиве. Далее через пробел записаны N чисел - элементы массива. Необходимо вывести все четные элементы массива (то есть те элементы, которые являются четными числами).
Ответы (1)
Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данныхСначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива.
Ответы (1)
Напишите программу, которая сортирует элементы массива по возрастанию последней цифры десятичной записи чисел. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)