Задать вопрос
5 августа, 18:38

Написать программу: Дан номер некоторого года (целое положительное число>1000). Определить соответствующий ему номер столетия, учитывая, что, к примеру, началом 20 столетия был 1901 год

+5
Ответы (1)
  1. 5 августа, 20:53
    0
    program century;

    var n, c: integer; / /n - номер года, с - столетие

    begin

    writeln ('Введите год (число больше тысячи');

    readln (n);

    c : = n div 100; / /число целых столетий

    if (n mod 100) >0 then c : = c + 1;

    //если число лет больше числа целых столетий,

    //то это будет уже следующее столетие - добавляем единицу.

    writeln (c, '-е столетие')

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу: Дан номер некоторого года (целое положительное число>1000). Определить соответствующий ему номер столетия, учитывая, ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Играют двое. Первый участник игры называет произвольное целое положительное число, не превышающее десяти, то есть он может назвать число десять и всякое меньшее десяти положительное число.
Ответы (1)
1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего - в куб и нахождения среднего арифметического полученных значений. 2.
Ответы (1)
Написать программу для решения следующей задачи: учебным заведением был приобретен стол за S руб. Его амортизация составляет 12% в год. Определить, сколько он будет стоить через N лет.
Ответы (1)
Написать программу для Паскаль через оператор Case. Для целого числа K от 1 до 99 напечаать фразу "мне K лет", учитывая при этом что при вводе некоторых значений K слово "лет" надо заменить на слово "год" или "года".
Ответы (1)