Задать вопрос

Написать программу для решения следующей задачи: учебным заведением был приобретен стол за S руб. Его амортизация составляет 12% в год. Определить, сколько он будет стоить через N лет. (Pascal) Пример: Введите стоимость стола: 35000 Введите кол-во лет: 5 Стоимость стола на конец 1 года: 30800.000 рублей Стоимость стола на конец 2 года: 27104.000 рублей Стоимость стола на конец 3 года: 23851.520 рублей Стоимость стола на конец 4 года: 20989.338 рублей Стоимость стола на конец 5 года: 18470.617 рублей

+1
Ответы (1)
  1. 29 марта, 11:01
    0
    var stoimost, i : integer;

    Stoimoststola, a : real;

    begin

    writeln ('Введите стоимость стола:');

    readln (Stoimoststola);

    writeln ('Введите количество лет:');

    readln (years);

    s:=0;

    for i:=1 to years do

    begin

    a:=Stoimoststola*0.12;

    a:=Stoimoststola-a;

    Stoimoststola:=a;

    Writeln ('Стоимость стола на конец ', i, ' года ', a, 'рублей');

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу для решения следующей задачи: учебным заведением был приобретен стол за S руб. Его амортизация составляет 12% в год. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)
Напишите программу на языке Паскаля для задачи: Ввести возраст человека (от 1 до 150) и ввести его вместе с последующими словами "год" года" "лет". Пример: Введите возраст: 24 Вам 24 года.
Ответы (1)
Составьте программу для решения следующей задачи. Введите с клавиатуры два числа: А и В. Если числа не равны, то замените каждое из них большим и выведите результаты на экран. Если они равны, то найдите и выведите удвоенную сумму этих чисел.
Ответы (1)
Ввести с клавиатуры координаты двух точек а и в на плоскости вещественный числа вычислить длину. программу нужно написать в паскале пример, как должно получиться введите координаты точки а 5.5 3.5 введите координаты точки b 1.5 2 длинна отрезка ab=4.
Ответы (1)
Ввести номер месяца и вывести количество дней в нем, а также число ошибок при вводе введите номер месяца: - 2 введите номер месяца: 2 введите номер месяца: 11 в этом месяце 28 дней в этом месяце 30 дней Вы вводили неверно 1 раз Вы вводили неверно 1
Ответы (1)