Задать вопрос

Оформить задачу на языке Паскаль - Элементы массива а циклически сдвинуть на 1 позицию влево, а первый и последний элементы поменять местами.

+2
Ответы (1)
  1. 13 марта, 19:38
    0
    program arr;

    const n = 40; / /задает число элементов массива

    var a: array [1 ... n] of integer;

    temp: integer;

    begin

    randomize;

    //Формирование массива

    for i: integer: = 1 to n do

    begin

    a[i]: = random (30);

    write (a[i] : 3);

    end;

    temp: = a[1];

    writeln ();

    //Сдвиг массива

    for i:integer: = 1 to n - 1 do a[i]: = a[i + 1];

    a[n]:=temp; / /первый и последний элемент - обмен значениями

    //вывод массива со сдвигом

    for i: integer: = 1 to n do write (a[i] : 3);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Оформить задачу на языке Паскаль - Элементы массива а циклически сдвинуть на 1 позицию влево, а первый и последний элементы поменять ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дан массив B (n*m). Элементы массива ввести в программе. Поменять местами максимальный и минимальный элемент. Паскаль двумерный массив пример присвоения элементов массива в программе : b: array[1 ... n, 1 ...
Ответы (1)
For i:=1 to N do Begin write ('C[', i,']='); readln (C[i]); end * Приведенный фрагмент программы, предназчен для 1 вывода массива в столбец 2 вывода массива в строку 3 формирования массива случайными числами 4 ввода массива с клавиатуры For i:=
Ответы (1)
Дан массив С размеров 10 элементов, элементы вводятся с клавиатуры. а) Найти сумму отрицательных элементов массива б) Поменять 1 и 5 элементы местами в) выполнить сортировку массива по возрастанию методом "пузырька"
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
Написать программу 1. в которой элементы двумерного массива равны сумме квадратов индексов, 2. которая циклически сдвигает заданный одномерный массив на один элемент вправо (при этом последний элемент оказывается на месте первого элемента).
Ответы (1)