Задать вопрос

1) Составить программу которая выводит на экран каждое 5-ое число и таких чисел 20.2) Составить программу которая вычисляет произведение натуральных чисел от 5 до 10.

+3
Ответы (1)
  1. 29 октября, 06:46
    0
    1. Первая программа:

    var i: integer;

    A: array [1 ... 20] of integer;

    begin

    randomize;

    writeln ('Рандомный массив: ');

    for i:=1 to 20 do A[i]:=random (21) - 10;

    for i:=1 to 20 do write (A[i]:5);

    writeln;

    writeln ('Вывод каждого пятого элемента на экран: ');

    for i:=1 to 20 do if i mod 5 = 0 then write (A[i]:5);

    end.

    2. Вторая программа:

    var x, i: integer;

    A: array [1 ... 20] of integer;

    begin

    randomize;

    writeln ('Рандомный массив: ');

    for i:=1 to 20 do A[i]:=random (11); for i:=1 to 20 do write (A[i]:5);

    writeln;

    writeln ('Вывод на экран натуральных числ в заданном диапазоне: ');

    for i:=5 to 10 do write (A[i]:5);

    writeln;

    x:=1;

    writeln ('Произведение натуральных чисел из диапазона: ');

    for i:=5 to 10 do x:=A[i]*x;

    write (x:5);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1) Составить программу которая выводит на экран каждое 5-ое число и таких чисел 20.2) Составить программу которая вычисляет произведение ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы