Задать вопрос

1) Напишите программу, которая определяет, является ли число нечётным. 2) Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n. 3) Напишите программу, которая генерирует 12 случайных чисел в диапазоне от 1 до 15, выводит эти числа на экран и вычисляет их среднее арифметическое.

+2
Ответы (1)
  1. 7 августа, 16:19
    0
    1) program zz1;

    var n:integer; / / задаем переменную целого типа

    begin

    write (' введите n '); / / вводим заданное n

    read (n);

    if n mod 2 = 0 then write (' число четное ') else write (' число не четное '); / / выводим ответ

    end.

    2) program zz1;

    var a, n, i, s:integer; / / задаем переменные целого типа

    begin

    write (' введите n '); / / вводим заданное n

    read (n);

    for i:=1 to n do

    s:=s+i; / / находим сумму натуральных чисел

    writeln ('сумма натуральных чисел от 1 до n = ', s); / / выводим ответ

    end.

    3) program zz1;

    const n = 12; / / задаем количество элементов в массиве

    var i, k, s:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (15) + 1;

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i:=1 to n do / / организуем цикл, в котором переберем все элементы массива

    if m[i] mod 3 = 0 then begin s:=s + m[i]; k:=k+1; end; / / получаем сумму и количество элементов кратных 3

    write (' среднее арифметическое элементов массива = ', s/k:5:2); / /выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1) Напишите программу, которая определяет, является ли число нечётным. 2) Напишите программу, которая вычисляет сумму всех чётных чисел в ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу которая генерирует 10 случайных чисел в диапазоне от 1 до 20 выводит эти числа на экран и вычисляет их среднее арефмитическое
Ответы (1)
1. Напишите программу, которая генерирует 10 случайных чисел от 1 до 20, выводит числа на экран и вычисляет их сред арифм. 2.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
Дано N случайных чисел в диапазоне от - 3 до 3. Вычислите, сколько из них не совпадают с 0. Составить программу, используя цикл for. Для задания случайных ч исел используйте функцию random. N определяет пользователь. Числа вывести на экран.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными индексами. выведите на экран исходный массив и полученное среднее арифметическое. 2.
Ответы (1)