Задать вопрос

Напишите программу, которая в последовательности натуральных чисел определяет максимальное, оканчивающееся на 1. Программа получает на вход кол-во чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 1. Количество чисел не превышает 1000. Введённые числа не превышают 30000. Программа должна вывести одно число - максимальное число, оканчивающееся на 1. Входны данные 3 11 21 31 Выходные данные 31

+3
Ответы (1)
  1. 26 декабря, 19:31
    0
    program max_n;

    const k = 5;

    //Проверить работоспособность на тысяче чисел трудно.

    //Задано количество чисел 5.

    //Можно заменить на k = 1000.

    var max, n, l: integer;

    procedure vvod (var n:integer);

    begin

    readln (n);

    if n > 30000 then

    begin

    writeln ('Число больше 30 000, введите меньшее число ');

    vvod (n);

    end

    end;

    begin

    writeln ('Введите число, не превышающее 30000');

    l:=0;

    n:=1;

    max:=1;

    while n>0 do

    begin

    vvod (n);

    l:=l+1;

    if l max then max:=n;

    if l = then

    begin

    writeln ('Количество чисел не может быть больше, чем ', k);

    writeln ('Максимальное число ', max);

    n:=0;

    end

    end;

    if l
    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу, которая в последовательности натуральных чисел определяет максимальное, оканчивающееся на 1. Программа получает на вход ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу в паскале, которая в последовательности натуральных чисел определяет максимальное число, кратное 4. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3.
Ответы (1)
Напишите программу, которая подсчитывает количество двузначных чисел в заданной последовательности натуральных чисел. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000.
Ответы (1)
Напишите программу, которая в последовательности целых чисел определяет максимальное число. программа получает на вход целые числа, количество введенных чисел неизвестно. последовательность числа заканчивается числом 0.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел, оканчивается на 2. Программа получает на выходе количество чисел в последовательности, а затем сами числа.
Ответы (1)