Задать вопрос

Напишите программу в паскале, которая в последовательности натуральных чисел определяет максимальное число, кратное 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4. Количество чисел не превышает 1000. Введенные числа не превышают 30 000. Программа должна вывести одно число - максимальное число, кратное 4.

+4
Ответы (1)
  1. 6 сентября, 23:10
    0
    var x: array[1 ... 1000] of integer;

    x1: array[1 ... 1000] of integer;

    n, i, j: integer;

    begin

    writeln ('Введите количество элементов в последовательности');

    readln (n);

    if n > 1000 then writeln ('Количество элементов больше 1000!') else

    begin

    for i : = 1 to n do x[i] = random (30000);

    for i : = 1 to n do if x[i] div 4 = 0 then begin

    j : = j + 1;

    x1[i] : = x[i];

    end;

    for i: = 1 to j do writeln (x1[i]:4);

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу в паскале, которая в последовательности натуральных чисел определяет максимальное число, кратное 4. Программа получает ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет максимальное, оканчивающееся на 1. Программа получает на вход кол-во чисел в последовательности, а затем сами числа.
Ответы (1)
Напишите программу, которая подсчитывает количество двузначных чисел в заданной последовательности натуральных чисел. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000.
Ответы (1)
Напишите программу, которая в последовательности N натуральных чисел определяет максимальное число, кратное 4. Программа получает на вход N-ное количество чисел. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел, оканчивается на 2. Программа получает на выходе количество чисел в последовательности, а затем сами числа.
Ответы (1)