Задать вопрос

Составьте программу для решения следующей задачи массив б задан случайным образом подсчитать сумму элементов массива состоящих из нечётных чисел

+5
Ответы (1)
  1. 16 апреля, 09:27
    0
    var a: array[1 ... 100] of integer;

    i, sum, n: integer;

    begin

    randomize;

    writeln ('Введите количество элементов массива');

    readln (n);

    for i:=1 to n do a[i]:=random (100);

    for i:=1 to n do if a[i] div 2 > 0 then sum:=sum+a[i];

    writeln ('Сумма нечётных элементов массива равна ', sum);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу для решения следующей задачи массив б задан случайным образом подсчитать сумму элементов массива состоящих из нечётных ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1 - Задан массив из N вещественных элементов. Заменить каждый элемент, кроме первого, суммой предыдущих элементов. 2 - Задан массив из N вещественных элементов. Найти минимальный из локальных минимумов данного массива.
Ответы (1)
Составить программы для паскаля для следующих задач: 1. В массиве из 10 элементов подсчитать количество нечетных элементов 2. Вычислить сумму квадратов элементов, больших 2. Массив состоит из 5 элементов действительного типа. 3. Даны два массива.
Ответы (1)
1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2.
Ответы (1)