Задать вопрос

1. Найти количество натуральных чисел, не превышающих 100 и кратных 5.2. Создать массив А из 10 элементов, принадлежащих промежутку (0; 25). Вывести полученный массив на экран. Подсчитать количество элементов, больших А [1]. Все с помощью Паскаля

+4
Ответы (1)
  1. 18 ноября, 22:55
    0
    1. program zz1;

    var r, i:integer; / / задаем переменные целого типа

    begin

    for i:=1 to 100 do

    if i mod 5 = 0 then r:=r + 1; / / вычисляем количество чисел

    write (' количество натуральных чисел кратных 5 = ', r); / /выводим ответ

    end.

    2. program zz1;

    const n = 10; / / задаем количество элементов в массиве

    var i, k:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (26);

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i:=2 to n do

    if m[i] > m[1] then k:=k+1;

    write (' количество таких членов = ', k);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1. Найти количество натуральных чисел, не превышающих 100 и кратных 5.2. Создать массив А из 10 элементов, принадлежащих промежутку (0; ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Создать массив а из десяти целых чисел, принадлежащих промежутку [0; 20). вывести полученный массив на экран. вычислить количество элементов массива, значения которых превышают средне арифметическое значений его элементов
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2.
Ответы (1)
Составить программы для паскаля для следующих задач: 1. В массиве из 10 элементов подсчитать количество нечетных элементов 2. Вычислить сумму квадратов элементов, больших 2. Массив состоит из 5 элементов действительного типа. 3. Даны два массива.
Ответы (1)