Задать вопрос
15 апреля, 01:47

Создать массив а из десяти целых чисел, принадлежащих промежутку [0; 20). вывести полученный массив на экран. вычислить количество элементов массива, значения которых превышают средне арифметическое значений его элементов

+1
Ответы (1)
  1. 15 апреля, 02:25
    0
    program zz1;

    const n = 10; / /задаем количество элементов в массиве

    var i, k, s, p:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / записываем в массив числа случайным образом

    m[i]:=random (21);

    for i:=1 to n do / /выводим массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i:=1 to n do

    s:=s+m[i];

    for i:=1 to n do

    if m[i] > s/n then p:=p + 1;

    writeln (' количество элементов больших среднего арифметического = ', p); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Создать массив а из десяти целых чисел, принадлежащих промежутку [0; 20). вывести полученный массив на экран. вычислить количество ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1. Найти количество натуральных чисел, не превышающих 100 и кратных 5.2. Создать массив А из 10 элементов, принадлежащих промежутку (0; 25). Вывести полученный массив на экран. Подсчитать количество элементов, больших А [1]. Все с помощью Паскаля
Ответы (1)
Дан одномерный массив чисел. Найти количество элементов массива, равных заданному числу, и вывести их номера. Найти сумму элементов массива, принадлежащих промежутку от а до b. Отрицательные элементы массива возвести в квадрат.
Ответы (1)