Задать вопрос

Вычислить сумму первых N чисел натурального ряда. Входные данные: Во входном потоке записано единственное целое число N (0 < N < = 100). Выходные данные: В выходной ноток вывести единственное целое число. Пример входного файла (input. txt) : 56 Пример выходного файла (output. txt) : 1596

+5
Ответы (1)
  1. 3 марта, 17:55
    0
    program zz1;

    var

    n, i, s: integer; / / задаем переменные целого типа

    f1, f2: text; / / задаем переменную текстового типа для работы с файлом

    begin

    assign (f1, 'input. txt'); / / связываем переменную текстового типа с файлом

    reset (f1); / / открываем файл для чтения

    assign (f2, 'output. txt');

    rewrite (f2); / / открываем файл для записи

    read (f1, n);

    for i:=1 to n do

    s: = s + i; / / получаем сумму

    write (f2, s); / / выводим ответ

    close (f1); / / закрываем файл input

    close (f2); / / закрываем файл output

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Вычислить сумму первых N чисел натурального ряда. Входные данные: Во входном потоке записано единственное целое число N (0 < N < = 100). ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Имя входного файла:E. in имя выходного файла E. out Дается ... Имя входного файла:E. in имя выходного файла E. out Дается последовательность из N чисел. найдите максимальное произ. среди всех пар этих чисел.
Ответы (1)
1) В каталоге находятся файлы со следующими именами: crab. txt crash. text cram. text chronos. txt traffic. txt ucraine. txt ucraine. tab Определите, по какой из масок будет выбрана указанная группа файлов: crab. txt crash. text cram. text ucraine.
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
По данному натуральному n вычислите сумму 12+22 + ... + n2. Входные данные Вводится единственное натуральное число n, не превосходящее 100 Выходные данные Необходимо вывести вычисленную сумму. Примеры входные данные 2 выходные данные 5
Ответы (1)
В некотором каталоге хранился файл txt. doc. После того, как в этом каталоге создали подкаталог и переместили в созданный подкаталог файл txt. doc, полное имя файла стало Р: doc / txt / letter / txt. doc.
Ответы (1)