Задать вопрос
1 сентября, 06:52

Вводится последовательность ненулевых чисел, 0 - конец последовательности. Определить наибольшее число в последовательности.

+4
Ответы (1)
  1. 1 сентября, 07:07
    0
    program zz1;

    var max, n:integer; / / задаем переменные целого типа

    begin

    write (' введите первое число '); / / вводим с клавиатуры число

    read (n);

    while n 0 do / / организуем цикла, в котором будем вводить числа последовательности, пока не будет введен ноль

    begin

    if n > max then max:=n; / / проверяем, если введенное число больше максимального, то записываем его в максимальное

    read (n); / / вводим с клавиатуры очередное число последовательности

    end;

    write (' наибольшее число в последовательности = ', max); / /выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Вводится последовательность ненулевых чисел, 0 - конец последовательности. Определить наибольшее число в последовательности. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Вводится последовательность ненулевых чисел; 0 - конец последовательности. Посчитать, сколько в ней отрицательных чисел, и сумму положительных чисел.
Ответы (1)
Вводится последовательность целых чисел, оканчивающаяся нулем. Число 0 в последовательность не входит. Выведите элементы последовательности в обратном порядке. Для хранения данных используйте стек.
Ответы (1)
Определите среднее арифметическое элементов последовательности, завершающейся числом 0. Число 0 в последовательность не входит. Числа, следующие за нулем, считывать не нужно. Входные данные Вводится последовательность целых чисел.
Ответы (1)
Дана непустая последовательность целых чисел, оканчивающаяся нулем (0 является признаком окончания последовательности и в последовательность не входит). Найти и напечатать: 1. Сумму всех чисел, больших Х (значение Х вводится с клавиатуры).
Ответы (1)
вводится последовательность чисел, 0 - конец последовательности. вычислить сумму чисел после первого отрицательного
Ответы (1)