Задать вопрос

Дана непустая последовательность целых чисел, оканчивающаяся нулем (0 является признаком окончания последовательности и в последовательность не входит). Найти и напечатать: 1. Сумму всех чисел, больших Х (значение Х вводится с клавиатуры). Если таких чисел нет, то напечатать "Таких чисел нет" 2. Количество четных чисел

+5
Ответы (1)
  1. 18 июля, 23:40
    0
    Чтобы найти сумму всех чисел, больших Х; количество четных чисел: var a:array[1 ... 1000] of longint; i, j, k, b, h, v:longint; begin i:=2; readln (a[1]); while (a[i-1]0) do begin readln (a[i]); inc (i); end; readln (j); for k:=1 to i-1 do if a[k]>j then h:=h+a[k] else inc (b); if b=i-1 then writeln ('таких чисел нет'); for k:=1 to i-1 do if a[k] mod 2=0 then inc (v); writeln (h, v); end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дана непустая последовательность целых чисел, оканчивающаяся нулем (0 является признаком окончания последовательности и в ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дана непустая последовательность чисел оканчивающаяся нулем. Найти: а) сумму всех чисел последовательности, б) кол-во всех чисел последовательности. решить через Pascal ABC через repeat, for или while
Ответы (1)
Вводится последовательность целых чисел, оканчивающаяся нулем. Число 0 в последовательность не входит. Выведите элементы последовательности в обратном порядке. Для хранения данных используйте стек.
Ответы (1)
1. Дана непустая последовательность целых чисел, оканчивающаяся нулем. Найти сумму всех чисел последовательности. Паскаль
Ответы (1)
Дана последовательность чисел, вводимых с клавиатуры и оканчивающаяся нулем. Составьте программу вычисления: a. суммы всех чисел последовательности; b. среднего арифметического всех чисел последовательности: c.
Ответы (1)
Дана непустая последовательность положительных целых чисел a1, a2, ... оканчивающаяся нулем. Получить a1, a1*a2, a1*a2*a3 ... 0 Решить, используя оператор until repeat либо while (паскаль)
Ответы (1)