Задать вопрос
23 апреля, 16:06

Дан массив из 20 натуральных чисел. Составить программу суммы элементов, кратных данному числу d.

+5
Ответы (1)
  1. 23 апреля, 17:24
    0
    Pascal ABC

    Const

    n=20;

    var a:array[1 ... n] of integer;

    var i, d, s:integer;

    begin

    s:=0;

    writeln ('Введите число d');

    readln (d);

    writeln ('Введите массив');

    for i:=1 to n do begin

    read (a[i]);

    if a[i] mod d = 0 then s:=s+a[i];

    end;

    writeln (s);

    end.

    Второй вариант выполнения:

    Program num1;

    Uses crt;

    Var

    a : array [1 ... 100] of integer;

    i, d, n, s : integer;

    Begin

    clrscr;

    s:=0;

    write ('D='); readln (d);

    write ('N='); readln (n);

    for i:=1 to n do

    readln (a[i]);

    for i:=1 to n do

    if (a[i] MOD d) = 0 then s:=s+a[i];

    writeln ('S=', s);

    End.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан массив из 20 натуральных чисел. Составить программу суммы элементов, кратных данному числу d. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика целых случайных чисел. Найдите сумму четных элементов массива. Выведите на экран исходный массив и полученную сумму. 2. Дан массив В (n). Определите произведение элементов, кратных 3.
Ответы (1)
1. Дан массив натуральных чисел. Найти сумму элементов кратных данному К. 2. В целочисленной последовательности есть нулевые элементы. Создать массив из номеров этих элементов. 3. дана последовательность целых чисел а1, а2, ... аn.
Ответы (1)
Решите одно из предложенных, умоляю дан массив А5 найти сумму и количество положительных элементов дан массив А5 определить количество отрицательных элементов дан массив А6 определить количество положительных элементов
Ответы (1)
1) задан массив из N элементов. вычислить среднее арифметическое тех элементов, которые кратны 3. 2) Задан массив из N элементов. Сформировать новый массив из элементов, кратных 7.
Ответы (1)