Задать вопрос

Найти ср. арифметическое элементов каждой из нечётных строк матрицы n-го порядка.

+1
Ответы (1)
  1. program zz1;

    const n = 8; / / задаем количество элементов в массиве

    var i, j, k, s:integer; / / задаем переменные целого типа

    m:array [1 ... n, 1 ... n] of integer;

    begin

    for i:=1 to n do

    for j:=1 to n do / / получаем числа и записываем их в массив

    m[i, j]:=random (101) - 50;

    for i:=1 to n do / / выводим полученный массив на экран

    begin

    for j:=1 to n do

    write (m[i, j]:4);

    writeln;

    end;

    for i:=1 to n do

    begin

    for j:=1 to n do

    if i mod 2 = 1 then begin k:=k + 1; s:=s + m[i, j]; end;

    if i mod 2 = 1 then writeln (' среднее арифметическое ', i, '-ой строки массива = ', s/k); / /выводим ответ

    s:=0;

    k:=0;

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найти ср. арифметическое элементов каждой из нечётных строк матрицы n-го порядка. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Ввести матрицу. Найти сумму четных элементов матрицы. Если она отрицательна, то заменить элементы четных столбцов матрицы на 1, в ином случае нечетных столбцов на - 1. Матрицу распечатать
Ответы (1)
Даны две квадратные матрицы А и В размером 3 х3. Требуется найти С=А х В. Составить программу нахождения числа строк матрицы А (N, N), сумма элементов у которых отрицательна. pascal abc
Ответы (1)
Дана вещественная квадратная матрица А порядка n. Найти среднее арифметическое среди положительных элементов матрицы, находящихся на главной и побочной диагоналях. Выдать сообщение, если таких элементов нет.
Ответы (1)
1. Имеется целочисленный массив, состоящий из 15 элементов: a) Найти сумму a[1] и a[7] элементов; b) Найти разность a[9] и a[3] элементов; c) Найти среднее арифметическое всех элементов массива; d) Найти произведение всех элементов массива.
Ответы (1)
Дан целочисленный массив из 2000 элементов. Если сумма всех элементов массива чётная, нужно вывести количество нечётных (по значению) элементов массива, если нечётная - количество чётных.
Ответы (1)