Задать вопрос
25 декабря, 14:49

22. Дан фрагмент программы, обрабатывающий массив А из 10 элементов: n : = 10; for i:=1 tо n do A[i] : = i; j : = 1; for i:=1 tо n-1 do if A[i] < A[i+1] then j : = j + 1; Чему будет равно значение переменной j после выполнения этого алгоритма?

+3
Ответы (1)
  1. 25 декабря, 15:02
    0
    Первый цикл выполнится 10 раз и в результате будет заполнен массив из 10 элементов числами от 1 до 10 (значение элемента равно индексу элемента).

    Второй цикл выполнится n - 1 раз, то есть 10 - 1 = 9 раз.

    В каждом цикле сравнивается текущий и следующий элемент. Элементы выстроены по возрастанию, поэтому 9 раз будет выполнено условие A[i]
    Ответ: 10.

    program ar;

    var n, j: integer;

    A: array [1 ... 10] of integer;

    begin

    n : = 10;

    for i: integer : =1 to n do

    A[i] : = i;

    j : = 1;

    for i: integer : = 1 to n - 1 do if A[i] < A[i + 1] then j : = j + 1;

    writeln (j)

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «22. Дан фрагмент программы, обрабатывающий массив А из 10 элементов: n : = 10; for i:=1 tо n do A[i] : = i; j : = 1; for i:=1 tо n-1 do if ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Чему будет равна переменная "c" после выполнения этой программы: a : = 28; b : = 7; b : = a div b + b; c : = a mod b + a; Ответ: 2. Чему будет равна переменная "c" после выполнения этой программы: a : = 26; b : = 6; c : = a mod b + b; Ответ: 3.
Ответы (1)
1. определить значение переменной А после выполнения оператора X:=5; if X>-3 then A:=X mod 2 else A:=abs (X); 2. определить значение переменной А после выполнения оператора X:=-26; Y:=6; if X div Y=4 then A:=X mod Y else A:=X*Y; 3.
Ответы (1)
1) Определите значение переменной s после выполнения следующего фрагмента программы: n : = 1; s : = 0; while n < = 101 do begin s : = s + 7; n : = n + 1 end; 2) Определите значение переменной S после выполнения следующего фрагмента программы: S:=1;
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a : = 3 + 8*4; b : = (a div 10) + 14; a : = (b mod 10) + 2;
Ответы (1)