Задать вопрос

1. дано слово. удвоить в нем все буквы, стоящие на четных местах 2. составьте программу, определяющую, на какую букву заканчивается второе слово в предложении

+5
Ответы (1)
  1. 5 июля, 15:13
    0
    1. program zz1;

    var s, s1:string; / / задаем переменные строкового типа

    i:integer; / / задаем переменную целого типа

    begin

    write (' введите строку ');

    read (s); / / вводим с клавиатуры строку

    s1:='';

    for i:=1 to length (s) do / / организуем цикл, в котором переберем все символы от первого до последнего

    begin

    if i mod 2 = 0 then begin s1:=s1+s[i]; s1:=s1+s[i]; end / / проверяем, если номер буквы четный, то в новую строку добавим эту букву два раза, если нечетный, то одну

    else s1:=s1+s[i];;

    end;

    write ('полученная строка = ', s1);

    end.

    2. program zz1;

    var s:string; / / задаем переменную строкового типа

    i, k:integer; / / задаем переменную целого типа

    begin

    write (' введите строку ');

    read (s); / / вводим с клавиатуры строку

    for i:=1 to length (s) - 1 do / / организуем цикл, в котором переберем все символы от первого до последнего

    begin

    if (s[i]' ') and (s[i+1]=' ') then begin k:=k+1; if k=2

    then write (' второе слово заканчивается на букву ', s[i]); end / / проверяем, если символ буква, а следующий пробел, то считаем, досчитали до 2, это и есть ответ

    end;

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1. дано слово. удвоить в нем все буквы, стоящие на четных местах 2. составьте программу, определяющую, на какую букву заканчивается второе ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы