Задать вопрос

Написать программу на Pascal ABC. Дано предложение. Вывести строку в обратном порядке. Вывести столбиком все его буквы "и", стоящие на четных местах.

+5
Ответы (1)
  1. 29 апреля, 01:10
    0
    program sentence;

    var s:string;

    i:integer;

    begin

    writeln ('Введите строку: ');

    Readln (s);

    for i: = 1 to length (s) do

    if i mod 2 = 0 then write (i mod 10) else write (' ');

    writeln ();

    for i:=length (s) downto 1 do write (s[i]);

    writeln ();

    for i: = 1 to length (s) do

    if (s[i] = 'и') then writeln (i, ' ', s[i]);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу на Pascal ABC. Дано предложение. Вывести строку в обратном порядке. Вывести столбиком все его буквы "и", стоящие на ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1. дано слово. удвоить в нем все буквы, стоящие на четных местах 2. составьте программу, определяющую, на какую букву заканчивается второе слово в предложении
Ответы (1)
Заполнить массив из 15 элементов числами из интервала от - 10 до 10 вывести в строчку и повторно вывести в строчку заменив все элементы стоящие на четных местах на число 5. На языке паскаль
Ответы (1)
Дан массив из 20 элементов, заполненный случайными числами в диапазоне от - 10 до + 10. Поменять местами элементы, стоящие на четных и нечетных местах и вывести на экран.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)