Задать вопрос

Напишите программу, которая вводит натуральные числа a и b и выводит все простые числа в диапазоне от a до b. Входные данные: Входная строка содержит два натуральных числа, a и b. Гарантируется, что a ≤ b. Выходные данные Программа должна вывести в одной строке через пробел все простые числа на отрезке [ a, b ]. Если таких чисел нет, программа должна вывести 0.

+4
Ответы (1)
  1. 22 декабря, 13:57
    0
    Var A, B, C, D, k:integer;

    Begin

    Write ('A = '); ReadLn (A);

    Write ('B = '); ReadLn (B);

    k:=0;

    For B: = A to B do

    Begin

    D:=0;

    For C: = 2 to B do

    if B mod C = 0 then D:=D+1;

    if D=1 then k:=k+1

    End;

    WriteLn (k);

    End.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу, которая вводит натуральные числа a и b и выводит все простые числа в диапазоне от a до b. Входные данные: Входная ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
С+ + Напишите программу, которая выводит номера элементов массива, равных заданному значению X. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
Напишите программу, которая заполняет массив первыми N натуральными числами и выводит его. Входные данные Входная строка содержит размер массива N. Гарантируется, что 0 < N ≤ 10000.
Ответы (1)
Напишите программу, которая сортирует элементы массива по возрастанию последней цифры десятичной записи чисел. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
Написать на Паскале Четные числа Входные данные Вводятся целые числа a и b. Гарантируется, что a не превосходит b Выходные данные Выведите (через пробел) все четные числа от a до b (включительно). входные данные 2 5 выходные данные 2 4
Ответы (1)