Задать вопрос
4 августа, 03:35

Составить программу поиска заданного числа в массиве из 10 целых чисел (массив одномерный)

+1
Ответы (1)
  1. 4 августа, 05:12
    0
    Программа на С++. Если в массиве несколько элементов равных заданному числу, выводится номер первого из них.

    #include

    using namespace std;

    int main ()

    {

    setlocale (LC_ALL, "Russian");

    int n;

    int i;

    int a[10];

    cout << "Введте число для поиска в массиве: " << endl;

    cin >> n;

    for (i = 0; i < 10; i++) {

    cout << "Введте элемент массива под номером: " << i + 1 << endl;

    cin >> a[i];

    if (a[i] = = n) {

    break;

    }

    }

    cout << "Данное число в массиве находится под номером : " << i + 1 << "." << endl;

    return 0;

    }
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу поиска заданного числа в массиве из 10 целых чисел (массив одномерный) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1) Написать программу, которая находит в массиве случайных символов первое вхождение заданного символа.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Найти минимальный чётный элемент в массиве и его индекс. 2) Заполнить одномерный массив степенями числа 2. Всего 10 элементов в массиве.
Ответы (1)