Задать вопрос
3 августа, 20:57

Дано трёхзначное число. Найти среди цифр этого числа, максимальное. Программа в Паскале

+5
Ответы (1)
  1. 3 августа, 22:38
    0
    program zz1;

    var i, s, k, p:integer; / / задаем переменные целого типа

    begin

    write (' введите трехзначное число'); / / вводим с клавиатуры число

    read (i);

    p:=i mod 10; / / находим последнюю цифру числа

    k:=i div 100; / / находим первую цифру числа

    s: = (i mod 100) div 10; / / находим среднюю цифру числа

    if (p > k) and (p > s) then writeln (' максимальная последняя цифра = ', p); / / выводим ответ

    if (k > p) and (k > s) then writeln (' максимальная первая цифра = ', k);

    if (s > k) and (s > p) then writeln (' максимальная средняя цифра = ', s);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано трёхзначное число. Найти среди цифр этого числа, максимальное. Программа в Паскале ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу в паскале, которая в последовательности натуральных чисел определяет максимальное число, кратное 4. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Установите соответствие: 1) базовое системное ПО а) операционная система 2) утилиты б) программа диагностики дисков в) антивирусная программа г) операционная оболочка д) программа архивации данных e) программа обслуживания сети
Ответы (1)
Напишите программу, которая в последовательности целых чисел определяет максимальное число. программа получает на вход целые числа, количество введенных чисел неизвестно. последовательность числа заканчивается числом 0.
Ответы (1)
Дано целое трехзначное число. Определить есть ли среди его цифр одинаковые. Формат входных данных Входной файл содержит неотрицательное трехзначное целое число.
Ответы (1)