Задать вопрос

дан массив из целых чисел X[1 ... 5]. Заменить каждый элемент массива с нечетным номером средним арифметическим индексов соседних элементов.

+5
Ответы (1)
  1. 24 октября, 01:38
    0
    Из задания не совсем понятно, что делать с крайними элементами. Например, 5-ый элемент - последний в массиве, соседний индекс слева - 4, а с права? В моей программе крайним элементам присваивается значение индекса единственного имеющегося соседа. Программа на С++.

    #include

    using namespace std;

    int main ()

    {

    int mas[5];

    for (int i = 1; i > mas[i];

    for (int i = 1; i < = 5; i = i+2)

    if (i==1) mas[i] = i + 1;

    else if (i==5) mas[i] = i - 1;

    else mas[i] = ((i-1) + (i+1)) / 2;

    for (int i = 1; i < = 5; i++) cout << mas[i]<< endl;

    }
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «дан массив из целых чисел X[1 ... 5]. Заменить каждый элемент массива с нечетным номером средним арифметическим индексов соседних элементов. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. Составить программу, которая вводит с клавиатура массив из 5 целых чисел и выводит на экран значение четвертого элемента массива. 2. Дан массив из 10 элементов, заполненный удвоенными значениями индексов элементов массива.
Ответы (1)
1. Дан одномерный массив из N элементов. Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2. Дан одномерный массив из Н элементов. Найти среднее арифметическое положительных четных элементов данного массива
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Дан массив, состоящий из целых чисел. Напишите программу, которая подсчитает количество элементов массива, больших предыдущего (элемента с предыдущим номером). Входные данные Сначала задано число N - количество элементов в массиве (1N10000).
Ответы (1)