Задать вопрос

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 6, 7, 5, 8, 3, 2, 0, 1, 9, 4 соответственно, т. е. A[0] = 6, A[1] = 7 и т. д. Определите зна - чение переменной c после выполнения следующего фрагмента этой программы c : = 0; for i : = 1 to 9 do if A[i] < A[0] then begin c : = c + 1; t : = A[i]; A[i] : = A[0]; A[0] : = t; end;

+2
Ответы (1)
  1. 3 июля, 18:38
    0
    Проверим ход программы по этапам. Каждый этап - это один проход цикла.

    Первый этап. Переменная i = 1.

    После сравнения первого и второго элемента получается, что второй больше, поэтому через данное условие программа не проходит.

    Второй этап. Переменная i = 2.

    После сравнения третьего и первого элемента получается, что третий меньше.

    Переменная с становится больше на единицу, а третий и первый элемент меняются местами.

    Таким образом программа продолжается, пока первым элементом не станет самый маленький элемент.

    Тогда с будет равно четырем, потому что меньше нуля элемента нет.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 6, 7, 5, 8, 3, 2, 0, 1, 9, 4 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Определите значение переменной s после выполнения следующего фрагмента программы: n : = 1; s : = 0; while n < = 101 do begin s : = s + 7; n : = n + 1 end; 2) Определите значение переменной S после выполнения следующего фрагмента программы: S:=1;
Ответы (1)
1. определить значение переменной А после выполнения оператора X:=5; if X>-3 then A:=X mod 2 else A:=abs (X); 2. определить значение переменной А после выполнения оператора X:=-26; Y:=6; if X div Y=4 then A:=X mod Y else A:=X*Y; 3.
Ответы (1)
6) Определите, что будет напечатано в результате работы следующего фрагмента программы: var n, s: integer; begin s : = 0; for n:=4 to 13 do begin s : = s + 15; end; write (s) end.
Ответы (1)
1. Чему будет равна переменная "c" после выполнения этой программы: a : = 28; b : = 7; b : = a div b + b; c : = a mod b + a; Ответ: 2. Чему будет равна переменная "c" после выполнения этой программы: a : = 26; b : = 6; c : = a mod b + b; Ответ: 3.
Ответы (1)
1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a : = 3 + 8*4; b : = (a div 10) + 14; a : = (b mod 10) + 2;
Ответы (1)