Задать вопрос

Составьте алгоритм вычисления суммы (PascalABC) : 1 + (1+2) + (1+2+3) + ... + (1+2 + ... + 10);

+4
Ответы (2)
  1. 9 сентября, 11:16
    0
    var a: array[1 ... 10] of integer;

    b: array[1 ... 100] of integer;

    i, j, y, n, sum: integer;

    begin

    n : = 1;

    for i : = 1 to 10 do a[i] : = i;

    for j : = 1 to 10 do

    for y : = 1 to n do begin

    b[j] : = b[j] + a[y];

    n : = n + 1;

    end;

    for i : = 1 to 10 do sum : = sum + b[i];

    writeln ('Решением заданной функции является', sum);

    end.
  2. 9 сентября, 14:51
    0
    1 + (1+2) = 4
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте алгоритм вычисления суммы (PascalABC) : 1 + (1+2) + (1+2+3) + ... + (1+2 + ... + 10); ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Запишите алгоритм вычисления для заданного количества суток (tfh) количества часов (Л), минут (т) и секунд (с). Выполните вычисления для заданных значений переменной tfh. Алгоритм: tfh 1 2 1/2 h т с
Ответы (1)
Составьте алгоритм вычисления суммы всех натуральных чисел, не привышающих заданного натурального числа N. Проверьте алгоритм трассировкой. Напишите программу в Паскале.
Ответы (1)
Что такое алгоритм? Зачем люди составляют и исполняют алгоритм. Какими разными способами можно описать способ решения задач? Как называют наглядную модель процесса решения задач? Какой алгоритм можно назвать линейным?
Ответы (1)
Разработать алгоритм для ввода четырёх целых чисел и вычисление их среднего арифметического. Протестировать алгоритм на исходных данных: - 5,8,-1,9. Линейный алгоритм
Ответы (1)
Дана цепочка символов СТОП. Какая цепочка символов получится, если к данной цепочке применить описанный алгоритм дважды (т. е. применить алгоритм к данной цепочке, а затем к результату вновь применить алгоритм) ?
Ответы (1)