Задать вопрос

Составьте алгоритм вычисления суммы всех натуральных чисел, не привышающих заданного натурального числа N. Проверьте алгоритм трассировкой. Напишите программу в Паскале.

+1
Ответы (1)
  1. 23 июня, 21:48
    0
    program zz1;

    var n, s, i: integer; / / задаем переменные целого типа

    begin

    s: = 0; / / задаем начальное значение суммы

    read (n); / / вводим число n с клавиатуры

    i:=1; / / задаем значение первого натурального числа

    while i < = n do / / организуем цикл, пока натуральное число не станет больше заданного n

    begin

    s:=s + i; / / прибавляем очередное натуральное число к сумме

    i: = i + 1; / / берем следующее натуральное число

    end;

    write (' полученная сумма натуральных чисел = ', s); / / выводим ответ на экран

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте алгоритм вычисления суммы всех натуральных чисел, не привышающих заданного натурального числа N. Проверьте алгоритм трассировкой. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Как составить на языке Паскаль программу вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа N? Вообще с Паскалем у меня полный завал! Если знаете как, то напишите! Желательно с объяснениями, буду благодарна!
Ответы (1)
Запишите алгоритм вычисления для заданного количества суток (tfh) количества часов (Л), минут (т) и секунд (с). Выполните вычисления для заданных значений переменной tfh. Алгоритм: tfh 1 2 1/2 h т с
Ответы (1)
Разработать алгоритм и составить программу вычисления значений суммы S заданного ряда при различных значениях аргумента Х: во внутреннем цикле для фиксированного значения Х поочередно суммировать члены ряда, пока их абсолютная величина превышает
Ответы (1)
Дана последовательность чисел, вводимых с клавиатуры и оканчивающаяся нулем. Составьте программу вычисления: a. суммы всех чисел последовательности; b. среднего арифметического всех чисел последовательности: c.
Ответы (1)