Задать вопрос
6 февраля, 17:22

найти сумму нечётных чисел, из промежутка от 11 до 99, найти среднее арифметическое чисел от 1 до 50

+3
Ответы (1)
  1. 6 февраля, 21:05
    0
    program zz1;

    var i, s, p, k:integer; / / задаем переменные целого типа

    begin

    for i:=11 to 99 do / / организуем цикл, в котором переберем числа от 11 до 99

    begin

    if i mod 2 = 1 then s:=s + i; / / проверяем, если число нечетное, то добавляем число в сумму

    end;

    writeln (' сумма нечетных чисел, из промежутка от 11 до 99 = ', s); / / выводим ответ

    for i:=1 to 50 do / / организуем цикл, в котором переберем числа от единицы до пятидесяти

    begin

    p:=p + i; / / добавляем число в сумму

    k:=k + 1; / / считаем количество

    end;

    writeln (' среднее арифметическое чисел от 1 до 50 = ', p/k); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «найти сумму нечётных чисел, из промежутка от 11 до 99, найти среднее арифметическое чисел от 1 до 50 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными индексами. выведите на экран исходный массив и полученное среднее арифметическое. 2.
Ответы (1)
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (1)
Найди сумму положительных нечётных чисел из промежутка от a до b, делящихся без остатка на 3
Ответы (1)
Загадано число из промежутка от 1 до 32. Какое количество информации необходимо для угадывания числа из этого промежутка?
Ответы (1)
Дан массив из 15 чисел заполненный случайными числами из интервала [-20; 20]. определить, что больше среднее арифметическое элементов стоящих на четных местах или среднее арифметическое положительных элементов массива
Ответы (1)