Задать вопрос
26 августа, 15:43

В массиве из 20 элементов заполненном целыми числами из интервала [10; 100] найти количество четных чисел оканчивающихся на цифру 4. Паскаль.

+3
Ответы (1)
  1. 26 августа, 19:03
    0
    program arr;

    var a: array [1 ... 20] of integer;

    n: integer; / / число элементов, оканчивающихся на цифру 4

    begin

    n:=0;

    writeln ('Печать массива');

    for var i:=1 to 20 do

    begin

    a[i] : = Random (90) + 10; / /случайное число в диапазоне 10 ... 100

    if (a[i] mod 10) = 4 then n:=n+1; / /подсчет числа элементов,

    //оканчивающихся на 4

    write (a[i],' '); / / печать элементов массива

    end;

    writeln ();

    writeln ('Число элементов массива, оканчивающихся на цифру 4 - ', n);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «В массиве из 20 элементов заполненном целыми числами из интервала [10; 100] найти количество четных чисел оканчивающихся на цифру 4. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. В массиве B[5,6], значения элементов находятся в интервале [-25,30]. Подсчитать количество элементов, значение которых кратно 4. 2. В массиве C[6,10], значения элементов находятся в интервале [10,30], найти сумму элементов в 1 строке. 3.
Ответы (1)
В массиве из 10 случайных чисел, заполненном из интервала [-10; 20], найти количество положительных элементов; подсчитать сумму элементов, стоящих на нечетных местах; заменить элементы массива, значения которых меньше 10, числом 10.
Ответы (1)
1. В цельночисленном массиве А (7) подсчитать количество элементов, больших числа 6? 2. В массиве Р (12) вычислить произведение всех четных элементов? (Язык Паскаль)
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Написать программу, которая выводит на экран значения элементов массива в обратном порядке. В массиве 10 элементов, массив заполняется с помощью случайных чисел из интервала (0, 100). (Паскаль)
Ответы (1)