Задать вопрос

Найти сумму элементов массива с четными индексами, значение которых превышает К. (паскаль)

+4
Ответы (1)
  1. 25 февраля, 23:29
    0
    program zz1;

    const n = 50; / / задаем количество элементов в массиве

    var i, s, k:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    write (' введите заданное число ');

    read (k);

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (21);

    for i:=1 to n do / / выводим полученный массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    for i:=1 to n do

    if (i mod 2 = 0) and (m[i] > k) then s:=s + m[i];

    writeln (' сумма элементов больших заданного и на четных номерах = ', s); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найти сумму элементов массива с четными индексами, значение которых превышает К. (паскаль) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
Составьте программу ввода с клавиатуры элементов массива a [1 ... 10] и вывода на экран элементов с чётными значениями и чётными индексами
Ответы (1)
Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данныхСначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива.
Ответы (1)
Дан массив B, в котором содержится 10 элементов целого типа. Найти: А) сумму элементов этого массива Б) произведение элементов этого массива В) Среднее арифметическое этого массива Нужен алгоритм паскаль Например: Program Summa; Var B:array (1 ...
Ответы (1)
1. Имеется целочисленный массив, состоящий из 15 элементов: a) Найти сумму a[1] и a[7] элементов; b) Найти разность a[9] и a[3] элементов; c) Найти среднее арифметическое всех элементов массива; d) Найти произведение всех элементов массива.
Ответы (1)