Задать вопрос

Составьте программу ввода с клавиатуры элементов массива a [1 ... 10] и вывода на экран элементов с чётными значениями и чётными индексами

+2
Ответы (1)
  1. 11 октября, 10:25
    0
    Вводим переменную для массива одномерного и состоящего из десяти элементов:

    var a : array [1 ... 10] of integer;

    begin

    Цикл проходит по элементам массива и заполняет их случайными числами:

    for i : integer : = 1 to 10 do

    a[i] : = random (20) - 10;

    Цикл проходит по элементам массива снова и проверяет, четные ли номера и четные ли элементы массива под этими номерами. Если да, выводит сообщение об этом:

    for i : integer : = 1 to 10 do

    if (a[i] mod 2 = 0) and (i mod 2 = 0) then

    writeln ('Под четным индексом ', i, ' находится четный элемент равный ', a[i]);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу ввода с клавиатуры элементов массива a [1 ... 10] и вывода на экран элементов с чётными значениями и чётными индексами ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
For i:=1 to N do Begin write ('C[', i,']='); readln (C[i]); end * Приведенный фрагмент программы, предназчен для 1 вывода массива в столбец 2 вывода массива в строку 3 формирования массива случайными числами 4 ввода массива с клавиатуры For i:=
Ответы (1)
Составьте программу ввода элементов массива b[1 ... 6] с клавиатуры и вывода на экран элементов с положительными значениями.
Ответы (1)
1. Составить программу ввода элементов массива A[1 ... 12]случайными целыми числами в диапазоне от - 10 до 10 и находит количество элементов с отрицательными значениями. 2. Составить программу ввода элементов массива A[1 ...
Ответы (1)
Составьте программу ввода с клавиатуры массива целых чисел a[1 ... 10] и вывода на экран элементов массива кратные 3.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)