Задать вопрос

Дан массив целых чисел. Поменять местами первый максимальный (если таковых несколько) и последний минимальный (если таковых несколько) по значению элементы массива. Число элементов в массиве не более 10-ти Pascal

+2
Ответы (1)
  1. 30 июля, 18:06
    0
    program zz1;

    const n = 10; / /задаем количество элементов в массиве

    var i, max1, min, k1, k2, v:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / записываем в массив числа случайным образом

    m[i]:=random (6);

    for i:=1 to n do / /выводим массив на экран

    write (m[i],' ');

    writeln; / / переходим на новую строку для вывода ответа

    max1:=0;

    for i:=n downto 1 do / / находим максимальный элемент

    if m[i]>=max1 then begin max1:=m[i]; k1:=i; end;

    writeln (' максимальный элемент = ', max1); / / выводим ответ

    min:=1000000; / /задаем начальное значение для минимального элемента

    for i:=1 to n do / / организуем цикл, в котором переберем все числа массива

    if m[i] < = min then begin min:=m[i]; k2:=i; end; / /проверяем, если число из массива меньше минимального, то записываем его в минимальное

    write (' минимальный элемент = ', min); / / выводим ответ

    writeln; / / переходим на новую строку для вывода ответа

    v:=m[k1]; m[k1]:=m[k2]; m[k2]:=v;

    for i:=1 to n do / /выводим массив на экран

    write (m[i],' ');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дан массив целых чисел. Поменять местами первый максимальный (если таковых несколько) и последний минимальный (если таковых несколько) по ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Дан массив B (n*m). Элементы массива ввести в программе. Поменять местами максимальный и минимальный элемент. Паскаль двумерный массив пример присвоения элементов массива в программе : b: array[1 ... n, 1 ...
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
Дан массив целых чисел. Нумерация элементов начинается с 0. Выведите все элементы массива с четными номерами. Формат входных данныхСначала задано число N - количество элементов в массиве, N100. Далее через пробел записаны N чисел - элементы массива.
Ответы (1)
1) Вычислите сумму элементов одномерного массива А (10). 2) Вычислите произведение элементов одномерного массива А (10). 3) Вычислите сумму четных чисел в массиве А (10). 4) Задан массив из N элементов. Определить максимальный (минимальный) элемент.
Ответы (1)