Задать вопрос

Линейный массив содержит сведения о количестве осадков, выпавших за каждый из 12 месяцев одного года. Составить программу, определяющую общее количество осадков за этот год, среднемесячное количество осадков, количество засушливых месяцев (когда количество осадков было меньше 30 мм), самый засушливый месяц года. для Turbo Pascal.

+3
Ответы (1)
  1. 31 июля, 07:21
    0
    var

    i, sum, min, y, z : integer; / / объявляем переменные целочисленного типа.

    arr : array [1 ... 12] of integer; / / объявляем массив.

    Begin

    writeln ('Введите количество осадков за каждый месяц в году, в мм:');

    for i: = 1 to 12 do / / начало цикла.

    begin

    read (arr[i]); / / считываем кол-во осадков за каждый месяц.

    if i = 1 then min : = arr[1]; / / считаем кол-во осадков в 1-й месяц минимальным.

    sum : = sum + arr[i]; / / считаем сумму осадков за год.

    if arr[i] < 30 then / / если месяц засушливый.

    begin

    z : = z + 1; / / считаем количество засушливых месяцев.

    if arr[i] < min then / / проверяем самый засушливый месяц.

    begin

    min : = arr[i];

    y : = i; / / присваиваем порядковый номер самому засушливому месяцу.

    end;

    end;

    end;

    writeln ('Сумма осадков за год в мм.: ', sum);

    writeln ('Среднемесячное количество осадков в мм.: ', round (sum / 12,2));

    writeln ('Количество засушливых месяцев в году: ', z);

    writeln (y, '-й месяц был самый засушливый в этом году');

    End.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Линейный массив содержит сведения о количестве осадков, выпавших за каждый из 12 месяцев одного года. Составить программу, определяющую ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы