Задать вопрос

Составить программу, которая меняет элементы массива на противоположные по знаку, массив заполняется с клавиатуры. Решить задачу на паскале.

+2
Ответы (1)
  1. 7 июля, 21:37
    0
    program zz1;

    const n = 5; / / задаем количество чисел в массиве

    var i:integer; / / задаем переменную целого типа для цикла

    m:array [1 ... n] of integer;

    begin

    for i:=1 to 5 do / / организуем цикл, в котором введем с клавиатуры n заданных чисел в массив

    read (m[i]);

    for i:=1 to 5 do / / организуем цикл, в котором число из массива умножим на - 1, в результате чего число в массиве поменяет знак на противоположный

    m[i]:=m[i] * (-1);

    for i:=1 to 5 do

    write (m[i], ' '); / / выводим полученные числа из массива в строчку через пробел

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу, которая меняет элементы массива на противоположные по знаку, массив заполняется с клавиатуры. Решить задачу на паскале. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
For i:=1 to N do Begin write ('C[', i,']='); readln (C[i]); end * Приведенный фрагмент программы, предназчен для 1 вывода массива в столбец 2 вывода массива в строку 3 формирования массива случайными числами 4 ввода массива с клавиатуры For i:=
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
Напишите программу, которая сортирует элементы массива по возрастанию последней цифры десятичной записи чисел. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
1. Дан массив натуральных чисел. Напечатать все элементы массива, являющиеся двузначными числами. 2. Дан массив. Напечатать четные элементы. 3. Все элементы массива с четными номерами удвоить, с нечетными - уменьшить на 1.
Ответы (1)