Задать вопрос

Напишите программу, которая по введённым с клавиатуры числам e, f и g будет вычислять значение коэффициентов a, b и c квдратного уравнения по предлагаемым формулам, а также значение дискриминанта D, решать это квадратное уравнение и выдавать результаты его решения. a=|e-f| (|e-f| - в третьей степени) b = корень из (3e + 17) (3e+17 - в четвёртой степени) c = (g-f) : 144, где D=b (в квадрате) - 4ac, корни уравнения x1,2 = (-b + - корень изD) : 2a отладьте программу на следующем примере: e=2 f=-2 g=3 a=64 b=529 c=0,0347222 d=279832 x1=-6<53267E-05 x2=-8,26556

+5
Ответы (1)
  1. 2 сентября, 13:06
    0
    var a, b, c, D, x1, x2:real;

    e, f, g:integer;

    begin

    writeln ("vvedite koefficienty: ");

    read (e);

    read (f);

    read (g);

    a:=sqr (abs (e-f)) * abs (e-f);

    b:=sqr (sqr (sqrt (3*e+17)));

    c: = (g-f) / 144;

    D:=sqr (b) - 4*a*c;

    x1: = (-b+sqrt (d)) / (2*a);

    x1: = (-b-sqrt (d)) / (2*a);

    writeln ("x1=", x1,"x2=", x2);

    readln

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу, которая по введённым с клавиатуры числам e, f и g будет вычислять значение коэффициентов a, b и c квдратного уравнения ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу, которая по двум катетам введённым с клавиатуры находит гипотенузу
Ответы (1)
1. Составте программу для нахождения граммов G в X унциях (1 унция = 28,35 грамма). Исходное количиство граммов задается с клавиатуры. 2. Напишите программу нахождения длин медиан m1, m2 и m3 треугольника по указанным формулам.
Ответы (1)
Составьте программу которая по трем введенным вами числам определит могут ли эти числа быть длинами сторон треугольника и если да то определить вид этого треугольника
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Напишите программу, вводящую с клавиатуры три числа А, В, С и проверяющую, существует ли треугольник со сторонами А, В, С. Программа должна выдавать ответ "да/нет".
Ответы (1)