Задать вопрос

Составьте программу которая по трем введенным вами числам определит могут ли эти числа быть длинами сторон треугольника и если да то определить вид этого треугольника

+4
Ответы (1)
  1. 20 июля, 12:02
    0
    Пишем программу:

    Pascal ABC.

    program qq;

    var

    a, b, c: real;

    begin

    writeln ('Введите два катета A, B и гипотенузу С треугольника');

    readln (a, b, c);

    if (c > = a + b) or (a + b + c = 0) then writeln ('Такого треугольника не существует')

    else begin

    if sqr (c) = sqr (a) + sqr (b) then writeln ('Прямоугольный');

    if sqr (c) > sqr (a) + sqr (b) then writeln ('Тупоугольный');

    if sqr (c) < sqr (a) + sqr (b) then writeln ('Остроугольный');

    end;

    end.

    Программа написана.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу которая по трем введенным вами числам определит могут ли эти числа быть длинами сторон треугольника и если да то ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике