Задать вопрос
8 января, 11:43

Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N.

+3
Ответы (1)
  1. 8 января, 12:07
    0
    program zz1;

    var i, n:integer; / / заводим переменные

    begin

    write ('введите n'); / / вводим заданное число n

    read (n);

    i:=1; / / задаем начальное значение цикла

    repeat

    write (i*i,' '); / / выводим квадраты числа на экран в строчку через пробел

    i:=i+1; / / увеличиваем параметр цикла на единицу

    until i*i>n; / / указываем условие окончания цикла

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N. Формат входных данных Задано единственное число N. Формат выходных данных Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.
Ответы (1)
Для 4 произвольных чисел, введенные с клавиатуры, выведите на экран соответствующие результаты. если разностьпервых двух чисел превышает четвертое, то выведите все четыре числа без изменения.
Ответы (1)
Напишите программу в паскаль для решения следующей задачи: для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты.
Ответы (1)
Выведите на экран в одну строку квадраты всех натуральных чисел, меньших данного N. В Pascal)
Ответы (1)
Дана строка. Найдите в этой строке второе вхождение буквы f, и выведите индекс этого вхождения. Если буква f в данной строке встречается только один раз, выведите число - 1, а если не встречается ни разу, выведите число - 2
Ответы (1)