Задать вопрос
17 мая, 22:57

Составить программу, которая позволит подсчитать сумму чётных чисел из диапазона 5-1000

+4
Ответы (1)
  1. 18 мая, 00:43
    0
    program zz1;

    var n, b:integer; / / задаем переменные целого типа

    begin

    for n:=5 to 1000 do / / организуем цикл, в котором переберем все числа от пяти до тысячи

    if (n mod 2 = 0) then b:=b + n; / / проверяем условие, если число из цикла делится на 2 без остатка, то прибавляем его к сумме

    write (' сумма четных чисел из заданного диапазона = ', b); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу, которая позволит подсчитать сумму чётных чисел из диапазона 5-1000 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Напишите программу, которая определяет, является ли число нечётным. 2) Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n.
Ответы (1)
1) Найдите сумму чисел из диапазона от А до В с шагом 3 2) Для заданного натурального n подсчитать сумму S = 1^2+2^2+3^2 + ... + n^2
Ответы (1)
Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих 256.
Ответы (1)
Написать программу. Ввести одномерный массив из целых чисел. Подсчитать во сколько раз сумма четных чисел массива превосходит среднее арифметическое всех чисел массива?
Ответы (1)
Составить программу, которая вычисляет сумму элементов главной диагонали в двумерном массиве размерности 3 х3. Заполнить массив целыми случайными числами из диапазона от 0 до 15.
Ответы (1)