Задать вопрос
29 декабря, 06:06

1) Определите значение переменной b после выполнения следующего фрагмента программы, где a и b - вещественные (действительные) переменные:a : = - 5; b : = 5 + 7 * a; b : = b / 2 * a;

+5
Ответы (1)
  1. 29 декабря, 07:17
    -1
    Начальные значения объявленных переменных: a = - 5; b = 5 + 7 * a.

    Программа в первую очередь высчитает значение переменной "b", прежде, чем переходить к этапу вычисления, где нужны обе переменные. Получаем следующее значение для "b": 5 + 7 * (-5) = - 30.

    Теперь мы переходим к решению второго равенства, только уже с другими значениями для переменных: a = - 5; b = - 30. Решаем равенство: - 30 / 2 * (-5) = 75.

    Итого, после выполнения всех действий программы, переменным присваиваются следующие значения: а = - 5; b = 75.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1) Определите значение переменной b после выполнения следующего фрагмента программы, где a и b - вещественные (действительные) переменные:a ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Определите значение переменной s после выполнения следующего фрагмента программы: n : = 1; s : = 0; while n < = 101 do begin s : = s + 7; n : = n + 1 end; 2) Определите значение переменной S после выполнения следующего фрагмента программы: S:=1;
Ответы (1)
1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a : = 3 + 8*4; b : = (a div 10) + 14; a : = (b mod 10) + 2;
Ответы (1)
1. Чему будет равна переменная "c" после выполнения этой программы: a : = 28; b : = 7; b : = a div b + b; c : = a mod b + a; Ответ: 2. Чему будет равна переменная "c" после выполнения этой программы: a : = 26; b : = 6; c : = a mod b + b; Ответ: 3.
Ответы (1)
1. определить значение переменной А после выполнения оператора X:=5; if X>-3 then A:=X mod 2 else A:=abs (X); 2. определить значение переменной А после выполнения оператора X:=-26; Y:=6; if X div Y=4 then A:=X mod Y else A:=X*Y; 3.
Ответы (1)
6) Определите, что будет напечатано в результате работы следующего фрагмента программы: var n, s: integer; begin s : = 0; for n:=4 to 13 do begin s : = s + 15; end; write (s) end.
Ответы (1)